View Issue Details

IDProjectCategoryView StatusLast Update
0002299fsvybrid_LinuxMatrix keyboardpublic2014-08-21 17:21
ReporterKeller Assigned To 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Versionfsvybrid-V2.0 
Target Versionfsvybrid-V2.1Fixed in Versionfsvybrid-V2.1 
Summary0002299: Matrix keyboard not working
DescriptionConfiguring the kernel to use the matrix keyboard results in a crashing kernel

Steps To ReproduceCustomer Report:

Today I installed the new fsvybrid V2.0 on my NetDCUA5. Woking, ok. Then I compiled a new kernel to activate the matrix keyboard. This leeds to a kernel - oops while booting. I changed the kernel configuration back to not using the matrix keyboard, this kernel is working ok. I tried a few more configs, diaable or enable several rows/columns, disable or enable the SPI port - always the same result: whenever the matrix keyboard is enabled, the kernel crashes during boot. Following is the Backtrace of the kernel:
[<80247f00>] (get_device_parent+0x0/0x16c) from [<8024861c>] (device_add+0x94/0x560)
r6:8fcf91a0 r5:8fcf9000 r4:8fcf9198 r3:8fcf36a0
[<80248588>] (device_add+0x0/0x560) from [<802ad3b8>] (input_register_device+0x244/0x348)
[<802ad174>] (input_register_device+0x0/0x348) from [<803d3908>] (matrix_keypad_probe+0x2ec/0x460)
r7:00000000 r6:804e8788 r5:8fcf9000 r4:8fc33700
[<803d361c>] (matrix_keypad_probe+0x0/0x460) from [<8024bffc>] (platform_drv_probe+0x1c/0x20)
[<8024bfe0>] (platform_drv_probe+0x0/0x20) from [<8024ad08>] (driver_probe_device+0xc0/0x19c)
[<8024ac48>] (driver_probe_device+0x0/0x19c) from [<8024ae54>] (__driver_attach+0x70/0x94)
r6:8050a384 r5:804e8624 r4:804e85f0 r3:00000000
[<8024ade4>] (__driver_attach+0x0/0x94) from [<80249c04>] (bus_for_each_dev+0x54/0x9c)
r6:8050a384 r5:8ffcfee8 r4:00000000 r3:8ffc70f4
[<80249bb0>] (bus_for_each_dev+0x0/0x9c) from [<8024a998>] (driver_attach+0x20/0x28)
r7:804fe6c8 r6:80049b1c r5:8fccd960 r4:8050a384
[<8024a978>] (driver_attach+0x0/0x28) from [<8024a5bc>] (bus_add_driver+0xe4/0x24c)
[<8024a4d8>] (bus_add_driver+0x0/0x24c) from [<8024b360>] (driver_register+0xb0/0x138)
[<8024b2b0>] (driver_register+0x0/0x138) from [<8024c3e4>] (platform_driver_register+0x4c/0x60)
[<8024c398>] (platform_driver_register+0x0/0x60) from [<8001d060>] (matrix_keypad_init+0x14/0x1c)
[<8001d04c>] (matrix_keypad_init+0x0/0x1c) from [<8002d418>] (do_one_initcall+0x9c/0x16c)
[<8002d37c>] (do_one_initcall+0x0/0x16c) from [<8000897c>] (kernel_init+0x80/0x11c)
[<800088fc>] (kernel_init+0x0/0x11c) from [<80049b1c>] (do_exit+0x0/0x5f8)
r5:800088fc r4:00000000
Code: e5963118 e593303c e5b30078 ea000007 (e590200c)
---[ end trace 3695f0a4cebe9c53 ]---
Forum Link


There are no notes attached to this issue.